[qutebrowser] PSA: :adblock-upgrade is broken

Florian Bruhin me at the-compiler.org
Tue Mar 7 22:53:14 CET 2017


Hi,

:adblock-upgrade is currently broken (read: crashes) because it
assumes the host block lists to be valid UTF-8, and one of the default
lists decided it was a good idea to include non-breaking spaces
encoded as latin1 in their comments in the last update...

If you run into this, please don't submit a crash report (I already
have >30 of them today :D), a new release will follow tomorrow.

The fix, if you're curious:
https://github.com/qutebrowser/qutebrowser/commit/c45019f0a0542ea684e5b57a3c8e34db551bc7bb

Florian

-- 
http://www.the-compiler.org | me at the-compiler.org (Mail/XMPP)
   GPG: 916E B0C8 FD55 A072 | http://the-compiler.org/pubkey.asc
         I love long mails! | http://email.is-not-s.ms/
-------------- next part --------------
A non-text attachment was scrubbed...
Name: signature.asc
Type: application/pgp-signature
Size: 833 bytes
Desc: not available
URL: <https://lists.schokokeks.org/pipermail/qutebrowser/attachments/20170307/8b8323a8/attachment-0001.asc>


More information about the qutebrowser mailing list