[qutebrowser] settings not keeping

Steve steve at 657.nyc
Mon Feb 18 15:47:03 CET 2019

So sorry for the misunderstanding! Qutebrowser has worked so well for me 
generally I never delved too deeply into settings and advanced 
functions. Thank you and will follow up on this shortly.

On 2/18/19 8:20 AM, Florian Bruhin wrote:
> On Sun, Feb 17, 2019 at 02:45:21PM -0500, Steve wrote:
>> On 2/17/19 2:42 PM, Florian Bruhin wrote:
>>> On Sun, Feb 17, 2019 at 02:23:19PM -0500, Steve wrote:
>>>> On Sun, Feb 17, 2019 at 02:01:10PM -0500, Steve wrote:
>>>>>> There is no autoconfig.yml at all in ~/.config/qutebrowser/
>>>>> Huh, but there was before the update?
>>>>> Florian
>>>> When things kept freezing up I did pacman -Rns qutebrowser to remove the
>>>> package completely from my system. Then I maually rm -rf
>>>> ~/.config/qutebrowser/ (sorry I didn't check its contents first to know if
>>>> that file was there or not).
>>>> After reinstalling (pacman -S qutebrowser) so far it has not frozen up (but
>>>> all freezes happened while brainzilla.com was open - I have previously
>>>> suspected some of their javascript of being a little "funny" - and I did not
>>>> test again yet that page. But the settings issue remains and there is no
>>>> autoconfig.yml file.
>>> So I assume you are using qute://settings? Does it work when using the
>>> :set command instead?
>>> You might want to use qutebrowser-git instead until I finish fixing up
>>> the remaining Qt 5.12 issues and release v1.6.0.
>>> Florian
>> I was using :set but just now tried qute://settings with same results,
>> settings do not keep.
> I just saw your report - you're just using the ":set" command without
> arguments, which opens qute://settings. That's expected to be broken in
> v1.5.2 with Qt 5.12 (but like I said, qutebrowser-git has it fixed).
> What I meant is using e.g. ":set downloads.remove_finished 3000" instead
> of using the webpage.
> Florian

More information about the qutebrowser mailing list